Fix system tray icons if disappear and are even disabled at the Settings


I have this nice SiteUp monitor utility which changes its system tray icon whenever a web site becomes unavailable. Unfortunately, although in the Windows Settings I activated permanently its icon, SiteUp from time to time disappears from the system tray and is hidden along with other hidden icons.

The strangest thing is that not only its icon won’t appear anymore at the system tray, but even the Windows Settings adjustment is deactivated! Then I activate it again, the icon shows up at the system tray but after some reboots or even at the very next reboot, the same problem is there and I need again to activate the system tray icon!

Here is how I fixed this issue. Instead of having SiteUp run automatically upon Windows Startup, I created a task with the Task Scheduler and I had SiteUp start with a delay of two minutes after I logged in Windows. It seems that SiteUp “rushed” to place its icon at the system tray and Windows had to deactivate the icon completely! Now that I delayed for a couple of minutes the opening of SiteUp, its icon is always visible at the system tray along with other icons I need to see all the time, and of course its adjustment at the Windows Settings remains activated.

If you face the same issue with some program, just try to delay its startup for a couple of minutes and see if that works for you too!

Report a problem on this page / Make a Request
Get The Power & Follow! don't miss   : :   Sleeper   Favorite Launcher   Savy   Gadgetarian
Fling   Power Copy   Windows Rule   SearchALL Gadget   Amazon Gadget